Two Years

Alot has changed since I last posted here,

Back then I was running the server on a 4 core with 8GB ram, the network relied on a SOHO off the shelf router.

Since then my network has gone threw a number of changes:

The main server was upgraded to a Dual CPU 6 core Xeon with 128 GB ram, I made the switch last year around this time to ZFS as my primary storage file system and wont ever look back at mdadm.

I had went through and made ‘compile cluster’ of three Gen 1 Raspberry pis running Gentoo, these ran relatively well but I never found a use for them outside of running AI battles of freeciv.

The above compile cluster was recently returned from the dead with a new batch of Gen 3 Pis all running 64 bit kernels. Two sit headless on a shelf operating my radius, dns and local ntp services, the third is my current workstation, and their shared portage repo. I also run Gentoo in a vm on the server ready to cross compile as needed.

The SOHO router started to over heat and shutdown, this was in the middle of a week I was working from home, I had just recently gotten the new server online and still had the ‘bones’ of the old one, Since then I have ran a few roll your own router distros:

4 core 8GB:
IPcop
*pfsense wouldn’t boot
IPFire, longest and most stable for this run ran for more then a year without problems.

I also tested switching From my tried and true KVM to ESX as school would provide it for a year. After a month I changed back, ESX seemed slow on my hardware for all my Linux machines but seemed much more optimized for windows, to bad I don’t run windows.. I did how ever get Mac OSX to install.

Around six months or so ago, my wife’s father happened on a rack system that was getting tossed, the gentleman who ran it passed away and his wife knew nothing about it and just wanted it gone, he asked if I wanted it.

From that I acquired:
42U Rack
Powerconnect 5448 48+4 port switch
Supermicro ‘NAS’ server 4 core Xeon with 8GB ram (Upgraded to 32GB) with 16 2TB drives
i5 with 16GB ram

Dual Core AMD, cant remember the ram as I haven’t used it.

Since then I racked My Dual Xeon and the router, after having issues with the 4 core router, I decided to upgrade to the i5 For a router. as When I went to the ‘roll your own’ I started down the squid(av,cache), snort, etc.. route and it eats alot of ram if you let it.

i5 16GB:
IPfire again long run until a friend at work showed me..
PFsense, would run for a few weeks then suddenly loose wan/route and i couldn’t get it back without re installing this lead to going back to.
IPFire, around this time 114 was out and both the installer and upgrader had issues I decided to check out
OPNsense and have run it ever since.

Everything racked from top down:

Switch
Dual Xeon
Router
SPACE
Supermicro Nas (on the bottom)

Network topology changed aswell, given now with the ‘roll your own’ distros I can have completely separate networks I have and mainly for now kept with the IPFire schema:

LAN, for everything Wired
Wireless, Selfexplanitory
L I have three access points in the house now, the original 1750AC a gifted 1900AC
both running as access points WPA-Enterprise, using the PIs radius for auth, then
an old 600n for legacy WPA2 with a direct line to the internet and nothing else.
Excom, Servers and such

LAN can access anything and any of the three networks, but both Wireless and Excom(unicated) can only talk to the internet and themselves.

For now I will leave this as my update.